aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaximilian attems <maks@stro.at>2007-02-21 09:36:39 +0000
committermaximilian attems <maks@stro.at>2007-02-21 09:36:39 +0000
commit426823465b4c2841085150123454c8cfc22782eb (patch)
tree4b132c4eaa3caefc858be9ac46963ff35bc77637
parent76875e5eb0d7f4069136baf691a6c7ab25a68a36 (diff)
downloadkernel_replicant_linux-426823465b4c2841085150123454c8cfc22782eb.tar.gz
kernel_replicant_linux-426823465b4c2841085150123454c8cfc22782eb.tar.bz2
kernel_replicant_linux-426823465b4c2841085150123454c8cfc22782eb.zip
Allow ide/pci/generic to claim chipsets as a a module or when built-in.
add patch by henj@hp.com svn path=/dists/sid/linux-2.6/; revision=8317
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/bugfix/ide_generic_all-boot-option.patch37
-rw-r--r--debian/patches/series/111
3 files changed, 40 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index de50138fb46e..b268f0b46f9d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -26,6 +26,7 @@ linux-2.6 (2.6.18.dfsg.1-11) UNRELEASED; urgency=low
- IB/mad: Fix race between cancel and receive completion
* Add 2.6.18.7, thanks gregkh:
- Fix a free-wrong-pointer bug in nfs/acl server (CVE-2007-0772)
+ * Allow ide_generic_all to be used modular and built in.
[ Steve Langasek ]
* debian/patches/bugfix/hp-laptop-acpi-blacklist.patch: ACPI-blacklist
@@ -34,7 +35,7 @@ linux-2.6 (2.6.18.dfsg.1-11) UNRELEASED; urgency=low
to prevent problems with memory leaks and heat stress at the expense
of battery control and S3 suspend support. Closes: #400488, #404143.
- -- Steve Langasek <vorlon@debian.org> Tue, 20 Feb 2007 15:26:59 -0800
+ -- maximilian attems <maks@sternwelten.at> Wed, 21 Feb 2007 10:34:37 +0100
linux-2.6 (2.6.18.dfsg.1-10) unstable; urgency=low
diff --git a/debian/patches/bugfix/ide_generic_all-boot-option.patch b/debian/patches/bugfix/ide_generic_all-boot-option.patch
new file mode 100644
index 000000000000..b8f73671a5a9
--- /dev/null
+++ b/debian/patches/bugfix/ide_generic_all-boot-option.patch
@@ -0,0 +1,37 @@
+commit a4bea10eca68152e84ffc4eaeb9d20ec2ac34664
+Author: Patrick Jefferson <henj@hp.com>
+Date: Tue Oct 3 01:14:34 2006 -0700
+
+ [PATCH] Allow ide_generic_all to be used modular and built in
+
+ Allow ide/pci/generic to claim chipsets as a a module or when built-in. It
+ requires using "all_generic_ide" as a boot option.
+
+ Signed-off-by: Patrick Jefferson <henj@hp.com>
+ Acked-by: Alan Cox <alan@redhat.com>
+ Closes-Bug: 7017
+ Signed-off-by: Andrew Morton <akpm@osdl.org>
+ Signed-off-by: Linus Torvalds <torvalds@osdl.org>
+
+diff --git a/drivers/ide/pci/generic.c b/drivers/ide/pci/generic.c
+index 78810ba..0cb7b9b 100644
+--- a/drivers/ide/pci/generic.c
++++ b/drivers/ide/pci/generic.c
+@@ -41,15 +41,8 @@
+
+ static int ide_generic_all; /* Set to claim all devices */
+
+-#ifndef MODULE
+-static int __init ide_generic_all_on(char *unused)
+-{
+- ide_generic_all = 1;
+- printk(KERN_INFO "IDE generic will claim all unknown PCI IDE storage controllers.\n");
+- return 1;
+-}
+-__setup("all-generic-ide", ide_generic_all_on);
+-#endif
++module_param_named(all_generic_ide, ide_generic_all, bool, 0444);
++MODULE_PARM_DESC(all_generic_ide, "IDE generic will claim all unknown PCI IDE storage controllers.");
+
+ static void __devinit init_hwif_generic (ide_hwif_t *hwif)
+ {
diff --git a/debian/patches/series/11 b/debian/patches/series/11
index 4b7c56429568..53bbcbbba104 100644
--- a/debian/patches/series/11
+++ b/debian/patches/series/11
@@ -7,3 +7,4 @@
+ bugfix/sparc/sbus-envctrl-remove-execve.patch
+ bugfix/nfs-acl-free-wrong-pointer.patch
+ bugfix/hp-laptop-acpi-blacklist.patch
++ bugfix/ide_generic_all-boot-option.patch