aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2006-08-15 13:51:58 +0000
committerBastian Blank <waldi@debian.org>2006-08-15 13:51:58 +0000
commit84109bfb6982110f6f890eba3a6ac3a88eb7d4eb (patch)
tree31b1e2e1667a8643d1e0ffc1eb3dbc94c6cd1754
parent41536396ce78e9c129cdcef2c9f5f56655b52675 (diff)
downloadkernel_replicant_linux-84109bfb6982110f6f890eba3a6ac3a88eb7d4eb.tar.gz
kernel_replicant_linux-84109bfb6982110f6f890eba3a6ac3a88eb7d4eb.tar.bz2
kernel_replicant_linux-84109bfb6982110f6f890eba3a6ac3a88eb7d4eb.zip
debian/rules.real: Fix building of xen images.
svn path=/dists/sid/linux-2.6/; revision=7163
-rw-r--r--debian/rules.real6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 392c2c8e4cef..e31137fe1cbd 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -374,14 +374,14 @@ install-image-$(ARCH)-$(SUBARCH)-$(FLAVOUR)-plain-xen:
dh_testdir
dh_testroot
dh_clean -d -k
- dh_installdirs -p$(PACKAGE_NAME) 'boot'
- dh_installdirs -p$(MODULES_PACKAGE_NAME) 'boot'
+ DH_OPTIONS= dh_installdirs -p$(PACKAGE_NAME) 'boot'
+ DH_OPTIONS= dh_installdirs -p$(MODULES_PACKAGE_NAME) 'boot'
cp $(DIR)/vmlinuz $(INSTALL_DIR)/vmlinuz-$(REAL_VERSION)
cd $(DIR); $(setup_env) make modules_install ARCH=$(KERNEL_ARCH) INSTALL_MOD_PATH=$(MODULES_PACKAGE_DIR)
cp $(DIR)/.config $(MODULES_PACKAGE_DIR)/boot/config-$(REAL_VERSION)
cp $(DIR)/System.map $(MODULES_PACKAGE_DIR)/boot/System.map-$(REAL_VERSION)
rm $(MODULES_PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/{build,source}
- $(MAKE) -f debian/rules.real install-base DH_OPTIONS='$(DH_OPTIONS)'
+ $(MAKE) -f debian/rules.real install-base
install-patch: PACKAGE = linux-patch-debian-$(VERSION)
install-patch: pbase := /usr/src/kernel-patches/all/$(SOURCE_UPSTREAM)