aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Michlmayr <tbm@cyrius.com>2006-06-27 09:31:46 +0000
committerMartin Michlmayr <tbm@cyrius.com>2006-06-27 09:31:46 +0000
commitc618859087766b198564c210216c88f22eac8c79 (patch)
tree911026a1b0ec97582c94c70a78c04e5cfde1555b
parent7bf6de02ead8349a9648d1e5c2b831d7613033c1 (diff)
downloadkernel_replicant_linux-c618859087766b198564c210216c88f22eac8c79.tar.gz
kernel_replicant_linux-c618859087766b198564c210216c88f22eac8c79.tar.bz2
kernel_replicant_linux-c618859087766b198564c210216c88f22eac8c79.zip
Add a build fix for the Cobalt early console support.
svn path=/dists/trunk/linux-2.6/; revision=6909
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/mips-cobalt-console.patch22
-rw-r--r--debian/patches/series/21
3 files changed, 24 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c2e0527b34a5..babe02b4db4c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ linux-2.6 (2.6.17-2) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* [mipsel] Fix compilation error in dz serial driver.
* [mipsel] Update configs.
+ * [mipsel] Add a build fix for the Cobalt early console support.
-- Jurij Smakov <jurij@debian.org> Sat, 24 Jun 2006 10:54:59 -0700
diff --git a/debian/patches/mips-cobalt-console.patch b/debian/patches/mips-cobalt-console.patch
new file mode 100644
index 000000000000..b757739b7464
--- /dev/null
+++ b/debian/patches/mips-cobalt-console.patch
@@ -0,0 +1,22 @@
+From: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
+Date: Wed, 7 Jun 2006 00:53:34 +0000 (+0900)
+Subject: [MIPS] Cobalt: Fix undefined reference to disable_early_printk.
+X-Git-Url: http://www.linux-mips.org/git?p=linux.git;a=commitdiff;h=973c789742b4dc957cd7feb96cae98988dd0cf01
+
+[MIPS] Cobalt: Fix undefined reference to disable_early_printk.
+
+Signed-off-by: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
+Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
+---
+
+--- a/arch/mips/cobalt/console.c
++++ b/arch/mips/cobalt/console.c
+@@ -41,3 +41,8 @@ void __init cobalt_early_console(void)
+
+ printk("Cobalt: early console registered\n");
+ }
++
++void __init disable_early_printk(void)
++{
++ unregister_console(&cons_info);
++}
diff --git a/debian/patches/series/2 b/debian/patches/series/2
index d52a6ff42831..ca4b991220e0 100644
--- a/debian/patches/series/2
+++ b/debian/patches/series/2
@@ -1 +1,2 @@
+ serial-dz.patch
++ mips-cobalt-console.patch