aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2006-06-28 19:18:11 +0000
committerBastian Blank <waldi@debian.org>2006-06-28 19:18:11 +0000
commit914ad8692495036aacba0ec2d95c766f9ac65a88 (patch)
treed66bd420bc6a2e887b57be64504513b89fe1b908
parente5162f059a137b8c888e9e1dc1969a4126ba0e98 (diff)
downloadkernel_replicant_linux-914ad8692495036aacba0ec2d95c766f9ac65a88.tar.gz
kernel_replicant_linux-914ad8692495036aacba0ec2d95c766f9ac65a88.tar.bz2
kernel_replicant_linux-914ad8692495036aacba0ec2d95c766f9ac65a88.zip
debian/rules.real
- Save ARCH into the headers package. - Set CROSS_COMPILE also. svn path=/dists/trunk/linux-2.6/; revision=6914
-rw-r--r--debian/rules.real7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 22bf54112655..7f19ed0a50b2 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -12,7 +12,7 @@ DEB_BUILD_ARCH := $(shell dpkg-architecture -a'$(ARCH)' -qDEB_BUILD_ARCH)
export PYTHONPATH = $(CURDIR)/debian/lib/python
export DH_OPTIONS
-export DEB_HOST_ARCH
+export DEB_HOST_ARCH DEB_HOST_GNU_TYPE DEB_BUILD_ARCH
#
# Build the list of common config files to be included
@@ -46,7 +46,6 @@ endif
setup_env := env -u ABINAME -u ARCH -u SUBARCH -u FLAVOUR -u VERSION -u LOCALVERSION
setup_makeflags =
ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
- setup_makeflags += CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)-
kpkg_image += --cross-compile='$(DEB_HOST_GNU_TYPE)'
endif
setup_env += MAKEFLAGS='$(setup_makeflags)'
@@ -138,8 +137,12 @@ define SETUP_DIR
cp -al '$(SOURCE_DIR)' '$(DIR)'
cp '$(CONFIG)' '$(DIR)/.config'
echo '$(ABINAME)$(LOCALVERSION)' > '$(DIR)/localversion'
+ echo 'ARCH = $(ARCH)' >> '$(DIR)/.kernelvariables'
echo 'CCACHE = ccache' >> '$(DIR)/.kernelvariables'
echo 'CC = $$(if $$(DEBIAN_KERNEL_USE_CCACHE),$$(CCACHE)) $$(CROSS_COMPILE)$(COMPILER)' >> '$(DIR)/.kernelvariables'
+ echo 'ifneq ($$(DEB_BUILD_ARCH),$$(DEB_HOST_ARCH))' >> '$(DIR)/.kernelvariables'
+ echo 'CROSS_COMPILE = $$(DEB_HOST_GNU_TYPE)-' >> '$(DIR)/.kernelvariables'
+ echo 'endif' >> '$(DIR)/.kernelvariables'
endef
$(STAMPS_DIR)/setup-$(ARCH)-$(SUBARCH)-$(FLAVOUR)-kernel-package: