aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samsung-ipc/tests/Makefile.am')
-rw-r--r--samsung-ipc/tests/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/samsung-ipc/tests/Makefile.am b/samsung-ipc/tests/Makefile.am
new file mode 100644
index 0000000..34925be
--- /dev/null
+++ b/samsung-ipc/tests/Makefile.am
@@ -0,0 +1,33 @@
+check_PROGRAMS = \
+ libsamsung-ipc-test \
+ $(NULL)
+
+libsamsung_ipc_test_SOURCES = \
+ tests/main.c \
+ tests/partitions/android.c \
+ tests/partitions/android.h \
+ $(NULL)
+
+libsamsung_ipc_test_SOURCES += $(libsamsung_ipc_la_SOURCES)
+
+libsamsung_ipc_test_LDADD = \
+ $(OPENSSL_LIBS) \
+ $(NULL)
+
+libsamsung_ipc_test_LDFLAGS =
+
+# As we reuse $(libsamsung_ipc_la_SOURCES) in the libsamsung-ipc-test test
+# program, we need to tell the autotools to separate the libsamsung-ipc and
+# libsamsung-ipc-test .o, otherwise libsamsung-ipc' .o will be linked
+# directoy in libsamsung-ipc-test.
+# As they need to be compiled with different options, this is an issue.
+# Without that we might have errors like this one during autogen.sh:
+# error: object 'ipc.$(OBJEXT)' created both with libtool and without
+libsamsung_ipc_test_CPPFLAGS = ${AM_CPPFLAGS}
+
+# TODO: Find a way to make test more modular and represent each run of
+# libsamsung-ipc-test in TEST while having it implemented in a single
+# python file
+PY_LOG_COMPILER = $(PYTHON)
+TEST_EXTENSIONS = .py
+TESTS = libsamsung-ipc-test.py