aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index 2bb18d9..ab33bba 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -14,20 +14,16 @@ lib_LTLIBRARIES = \
libsamsung-ipc.la \
$(NULL)
-libsamsung_ipc_la_SOURCES = \
- $(NULL)
-
+# This defines libsamsung_ipc_la_SOURCES so we can reuse it in
+# samsung-ipc/test/Makefile.am
include $(top_srcdir)/samsung-ipc/common/Makefile.am
-include $(top_srcdir)/samsung-ipc/devices/Makefile.am
-include $(top_srcdir)/samsung-ipc/modems/Makefile.am
-include $(top_srcdir)/samsung-ipc/partitions/Makefile.am
libsamsung_ipc_la_LIBADD = \
$(OPENSSL_LIBS) \
$(NULL)
-# As we reuse $(libsamsung_ipc_la_SOURCES) in the libsamsung-ipc-test test
-# program, we need to tell the autotools to separate the libsamsung-ipc and
+# As we reuse $(libsamsung_ipc_la_SOURCES) in samsung-ipc/common/Makefile.am,
+# we need to tell the autotools to separate the libsamsung-ipc and
# libsamsung-ipc-test .o, otherwise libsamsung-ipc' .o will be linked
# directoy in libsamsung-ipc-test.
# As they need to be compiled with different options, this is an issue.