aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am72
1 files changed, 55 insertions, 17 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index 1cf760d..da7680c 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -15,25 +15,63 @@ lib_LTLIBRARIES = \
$(NULL)
libsamsung_ipc_la_SOURCES = \
- ipc.c \
- ipc.h \
- ipc_utils.c \
- utils.c \
- call.c \
- sms.c \
- sec.c \
- net.c \
- misc.c \
- svc.c \
- gprs.c \
- rfs.c \
- gen.c \
+ $(top_srcdir)/samsung-ipc/ipc.c \
+ $(top_srcdir)/samsung-ipc/ipc.h \
+ $(top_srcdir)/samsung-ipc/ipc_utils.c \
+ $(top_srcdir)/samsung-ipc/utils.c \
+ $(top_srcdir)/samsung-ipc/call.c \
+ $(top_srcdir)/samsung-ipc/sms.c \
+ $(top_srcdir)/samsung-ipc/sec.c \
+ $(top_srcdir)/samsung-ipc/net.c \
+ $(top_srcdir)/samsung-ipc/misc.c \
+ $(top_srcdir)/samsung-ipc/svc.c \
+ $(top_srcdir)/samsung-ipc/gprs.c \
+ $(top_srcdir)/samsung-ipc/rfs.c \
+ $(top_srcdir)/samsung-ipc/gen.c \
+ $(top_srcdir)/samsung-ipc/devices/ipc_devices.c \
+ $(top_srcdir)/samsung-ipc/devices/ipc_devices.h \
+ $(top_srcdir)/samsung-ipc/devices/crespo/crespo.c \
+ $(top_srcdir)/samsung-ipc/devices/crespo/crespo.h \
+ $(top_srcdir)/samsung-ipc/devices/crespo/crespo_modem_ctl.h \
+ $(top_srcdir)/samsung-ipc/devices/aries/aries.c \
+ $(top_srcdir)/samsung-ipc/devices/aries/aries.h \
+ $(top_srcdir)/samsung-ipc/devices/aries/onedram.h \
+ $(top_srcdir)/samsung-ipc/devices/aries/phonet.h \
+ $(top_srcdir)/samsung-ipc/devices/galaxys2/galaxys2.c \
+ $(top_srcdir)/samsung-ipc/devices/galaxys2/galaxys2.h \
+ $(top_srcdir)/samsung-ipc/devices/maguro/maguro.c \
+ $(top_srcdir)/samsung-ipc/devices/maguro/maguro.h \
+ $(top_srcdir)/samsung-ipc/devices/piranha/piranha.c \
+ $(top_srcdir)/samsung-ipc/devices/piranha/piranha.h \
+ $(top_srcdir)/samsung-ipc/devices/i9300/i9300.c \
+ $(top_srcdir)/samsung-ipc/devices/i9300/i9300.h \
+ $(top_srcdir)/samsung-ipc/devices/n7100/n7100.c \
+ $(top_srcdir)/samsung-ipc/devices/n7100/n7100.h \
+ $(top_srcdir)/samsung-ipc/devices/n5100/n5100.c \
+ $(top_srcdir)/samsung-ipc/devices/n5100/n5100.h \
+ $(top_srcdir)/samsung-ipc/devices/herolte/herolte.c \
+ $(top_srcdir)/samsung-ipc/devices/herolte/herolte.h \
+ $(top_srcdir)/samsung-ipc/devices/generic/generic.c \
+ $(top_srcdir)/samsung-ipc/devices/generic/generic.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm616/xmm616.c \
+ $(top_srcdir)/samsung-ipc/modems/xmm616/xmm616.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626.c \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_hsic.c \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_hsic.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_kernel_smdk4412.c \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_kernel_smdk4412.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_mipi.c \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_mipi.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_modem_if.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_modem_link_device_hsic.h \
+ $(top_srcdir)/samsung-ipc/modems/xmm626/xmm626_modem_prj.h \
+ $(top_srcdir)/samsung-ipc/partitions/android/android.c \
+ $(top_srcdir)/samsung-ipc/partitions/android/android.h \
+ $(top_srcdir)/samsung-ipc/partitions/toc/toc.c \
+ $(top_srcdir)/samsung-ipc/partitions/toc/toc.h \
$(NULL)
-include devices/Makefile.am
-include modems/Makefile.am
-include partitions/Makefile.am
-
libsamsung_ipc_la_LIBADD = \
$(OPENSSL_LIBS) \
$(NULL)