aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-03-02 16:34:01 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-03-02 17:02:18 +0100
commitcd80f4ce927a59634894c983471aa0db78ad93a0 (patch)
tree9dd27ccd5ca48bdf67da581596de374529a4347f /samsung-ipc/Makefile.am
parent3bcc9e2a31c970ee3e6a6a5c57f1df83ddb77857 (diff)
downloadhardware_replicant_libsamsung-ipc-cd80f4ce927a59634894c983471aa0db78ad93a0.tar.gz
hardware_replicant_libsamsung-ipc-cd80f4ce927a59634894c983471aa0db78ad93a0.tar.bz2
hardware_replicant_libsamsung-ipc-cd80f4ce927a59634894c983471aa0db78ad93a0.zip
test: reuse libsamsung-ipc source files
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index 2bb18d9..ab33bba 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -14,20 +14,16 @@ lib_LTLIBRARIES = \
libsamsung-ipc.la \
$(NULL)
-libsamsung_ipc_la_SOURCES = \
- $(NULL)
-
+# This defines libsamsung_ipc_la_SOURCES so we can reuse it in
+# samsung-ipc/test/Makefile.am
include $(top_srcdir)/samsung-ipc/common/Makefile.am
-include $(top_srcdir)/samsung-ipc/devices/Makefile.am
-include $(top_srcdir)/samsung-ipc/modems/Makefile.am
-include $(top_srcdir)/samsung-ipc/partitions/Makefile.am
libsamsung_ipc_la_LIBADD = \
$(OPENSSL_LIBS) \
$(NULL)
-# As we reuse $(libsamsung_ipc_la_SOURCES) in the libsamsung-ipc-test test
-# program, we need to tell the autotools to separate the libsamsung-ipc and
+# As we reuse $(libsamsung_ipc_la_SOURCES) in samsung-ipc/common/Makefile.am,
+# we need to tell the autotools to separate the libsamsung-ipc and
# libsamsung-ipc-test .o, otherwise libsamsung-ipc' .o will be linked
# directoy in libsamsung-ipc-test.
# As they need to be compiled with different options, this is an issue.