summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-11-07 15:30:55 +0000
committerEric Engestrom <eric@engestrom.ch>2019-10-14 16:07:20 +0000
commitf057dc91e93ae21e11ab48a26127d569972f3eae (patch)
tree59debcac996929cf2c0235309318981ed853171d /tests/Makefile.am
parente4f090f3c23d7b92068ee182a277700ba3988c36 (diff)
downloadexternal_libdrm-f057dc91e93ae21e11ab48a26127d569972f3eae.tar.gz
external_libdrm-f057dc91e93ae21e11ab48a26127d569972f3eae.tar.bz2
external_libdrm-f057dc91e93ae21e11ab48a26127d569972f3eae.zip
libdrm: remove autotools support
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
deleted file mode 100644
index d274a3e90..000000000
--- a/tests/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-SUBDIRS = util kms modeprint proptest modetest vbltest
-
-if HAVE_LIBKMS
-SUBDIRS += kmstest
-endif
-
-if HAVE_RADEON
-SUBDIRS += radeon
-endif
-
-if HAVE_AMDGPU
-if HAVE_CUNIT
-SUBDIRS += amdgpu
-endif
-endif
-
-if HAVE_EXYNOS
-SUBDIRS += exynos
-endif
-
-if HAVE_TEGRA
-SUBDIRS += tegra
-endif
-
-if HAVE_ETNAVIV
-SUBDIRS += etnaviv
-endif
-
-if HAVE_NOUVEAU
-SUBDIRS += nouveau
-endif
-
-AM_CFLAGS = \
- $(WARN_CFLAGS)\
- -fvisibility=hidden \
- -I $(top_srcdir)/include/drm \
- -I $(top_srcdir)
-
-LDADD = $(top_builddir)/libdrm.la
-
-TESTS = \
- drmsl \
- hash \
- random
-
-check_PROGRAMS = \
- $(TESTS)
-
-if HAVE_INSTALL_TESTS
-bin_PROGRAMS = drmdevice
-else
-check_PROGRAMS += drmdevice
-endif