aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2019-09-11 13:33:50 -0700
committerHaibo Huang <hhb@google.com>2019-09-13 17:10:15 -0700
commit445085ad1110e215636704c9530ba16ae3e87329 (patch)
tree188fe35e9e36175e8c9e544b7d48b8cbac8b1907 /CMakeLists.txt
parente45b87230b7f4e37d29d2d29847415e1d1e5defa (diff)
downloadexternal_curl-445085ad1110e215636704c9530ba16ae3e87329.tar.gz
external_curl-445085ad1110e215636704c9530ba16ae3e87329.tar.bz2
external_curl-445085ad1110e215636704c9530ba16ae3e87329.zip
Upgrade curl to curl-7_66_0
Test: None Change-Id: I3b08841f93c0f51cca6ec168fe43b891f2ad58f1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29cb5f59..0772d6e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,7 +260,7 @@ if(ENABLE_THREADED_RESOLVER)
endif()
# Check for all needed libraries
-check_library_exists_concat("dl" dlopen HAVE_LIBDL)
+check_library_exists_concat("${CMAKE_DL_LIBS}" dlopen HAVE_LIBDL)
check_library_exists_concat("socket" connect HAVE_LIBSOCKET)
check_library_exists("c" gethostbyname "" NOT_NEED_LIBNSL)
@@ -860,6 +860,7 @@ check_symbol_exists(strlcat "${CURL_INCLUDES}" HAVE_STRLCAT)
check_symbol_exists(getpwuid "${CURL_INCLUDES}" HAVE_GETPWUID)
check_symbol_exists(getpwuid_r "${CURL_INCLUDES}" HAVE_GETPWUID_R)
check_symbol_exists(geteuid "${CURL_INCLUDES}" HAVE_GETEUID)
+check_symbol_exists(usleep "${CURL_INCLUDES}" HAVE_USLEEP)
check_symbol_exists(utime "${CURL_INCLUDES}" HAVE_UTIME)
check_symbol_exists(gmtime_r "${CURL_INCLUDES}" HAVE_GMTIME_R)
check_symbol_exists(localtime_r "${CURL_INCLUDES}" HAVE_LOCALTIME_R)